summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Lamskoy2023-10-13 12:54:45 +0300
committerEugene Lamskoy2023-10-13 12:54:45 +0300
commit98b35c440b932973d83cbd43cb2373cf51b6e73e (patch)
tree0ee65c782aadc7972c61c149f47c30d7f467f628 /PKGBUILD
parent3a3e5fc2a2aa6889d0de53612a00b86cbdd9b73f (diff)
downloadaur-98b35c440b932973d83cbd43cb2373cf51b6e73e.tar.gz
Removed commented out code
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e87e1d16a099..a4d89a6dba95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,8 +28,8 @@ build() {
--without-manpages --without-tests --without-pkg-config \
--with-static --with-cxx-static --with-abi-version=5
make clean
-# make -j8
-# make DESTDIR="${srcdir}/ncurses" install
+ make -j$(nproc)
+ make DESTDIR="${srcdir}/ncurses" install
popd
pushd "${pkgname}"
make WIDE_NCURSES=1 USE_NCURSES=1 KOI8=1
@@ -64,15 +64,15 @@ prepare() {
}
pkgver() {
- cd "$pkgname"
+ pushd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ popd
}
package() {
pushd "${_ncurses}-${_ncurses_pkgver}"
make DESTDIR="${pkgdir}" install
popd
-
pushd "${pkgname}"
mkdir -m 755 -p "${pkgdir}/usr/share/goldedplus"/{docs,charset,colorset,config,template}
install -d "${pkgdir}/usr/bin"