summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorshenleban tongying2023-06-12 02:23:12 -0400
committershenleban tongying2023-06-12 02:23:12 -0400
commit48b9aafc67580601e0e238eb62fe2024a9b37fdb (patch)
treee908d195571bc092aea2dde6c5e31a9b8c3604d4 /PKGBUILD
parent04e531a7e3bcc47d211a76a95efd535b13bbb025 (diff)
downloadaur-48b9aafc67580601e0e238eb62fe2024a9b37fdb.tar.gz
simplify pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6fcb377f231..43f01f109f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: slbtty <shenlebantongying@gmail.com>
pkgname=goldendict-ng-git
-pkgver=23.05.03.alpha.230526.defc2447.r3.g3858932e
+pkgver=23.06.02.a2f5aa6c
pkgrel=1
pkgdesc="A feature-rich dictionary lookup program, supporting multiple dictionary formats."
arch=('i686' 'x86_64')
@@ -21,7 +21,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "%s.%s" "$(git describe | cut -c 2-9)" "$(git rev-parse --short HEAD)"
}
prepare() {