summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBernd Schoolmann2023-08-20 23:35:12 +0200
committerBernd Schoolmann2023-08-20 23:35:12 +0200
commitb12a877523e5583680498929177c32633615f4de (patch)
treed228836457b269eeee905f5546e8c8b0eea1394a /PKGBUILD
downloadaur-b12a877523e5583680498929177c32633615f4de.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62f7bd0843f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Bernd Schoolmann mail@quexten.com
+
+pkgname=goldwarden
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='A feature-packed Bitwarden compatible desktop integration'
+arch=('x86_64')
+url="https://github.com/quexten/$pkgname"
+license=('MIT')
+makedepends=('go' 'libfido2' 'gcc' 'wayland' 'libx11' 'libxkbcommon' 'libxkbcommon-x11' 'libxcursor' 'base-devel' 'vulkan-headers')
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('7d38db887437a58758e5f183d4951cf7c4d1b099f37ff6f5e95fb98735634983')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+ export CGO_ENABLED=1
+
+ go mod tidy
+ go build -tags autofill -o build/$pkgname .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ echo $pkgdir
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+