summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeimos2018-08-21 02:29:19 -0400
committerDeimos2018-08-21 02:29:19 -0400
commit6585cd5a386e79f40fa652471c3ac4e12f958b1a (patch)
tree17532ff7dd6e8c15fa6061743b2c03fce7923308 /PKGBUILD
downloadaur-6585cd5a386e79f40fa652471c3ac4e12f958b1a.tar.gz
Stage for AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb8c8224aa6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+pkgname=gomoku.app
+_pkgname=Gomoku
+pkgrel=1
+pkgver=1.2.9
+pkgdesc="Extended TicTacToe game for GNUstep"
+arch=('i686' 'x86_64')
+url="http://www.gnustep.it/nicola/Applications/Gomoku/"
+license=('GPL')
+groups=('gnustep-games')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://www.gnustep.it/nicola/Applications/Gomoku/Gomoku-1.2.9.tar.gz")
+sha256sums=('1d3680559747deb7fbf35dc67d08e99e979961f146676cca1259a7e25185c5a2')
+
+prepare(){
+# Fix Icon
+ cd $_pkgname-$pkgver
+ icon=' NSIcon = "Gomoku.png";'
+ sed -i "9s@^.*@$icon@;s/.app//" GomokuInfo.plist
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file