summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorraziman2020-08-23 11:42:44 +0800
committerraziman2020-08-23 11:43:28 +0800
commita92c27d4e60aae5be062cab75e548a1ee07dbf8b (patch)
tree7e9e00dace29a683adb32442f456d1a6359a377c /PKGBUILD
parentabd13272a765815a2f505de57503384d5cb72b63 (diff)
downloadaur-a92c27d4e60aae5be062cab75e548a1ee07dbf8b.tar.gz
add checksum and change source
add checksum and change source file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e371c996c7e..889cccd3fe59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Raziman Mahathir <raziman.mahathir@gmail.com>
pkgname='gomu'
-pkgver=v1.5.5
+pkgver=1.5.5
pkgrel=2
pkgdesc="Terminal User Interface (TUI) Music Player"
arch=('x86_64')
@@ -11,20 +11,16 @@ depends=('alsa-lib' 'youtube-dl' 'noto-fonts-emoji')
makedepends=('go' 'git')
optdepends=('fzf')
conflicts=('gomu-git' 'gomu-bin')
-source=("git://github.com/issadarkthing/gomu.git")
-md5sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/issadarkthing/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0c386dac1666fbb0d26738686f1e0198')
-pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make build
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
install -Dm755 ./bin/gomu "$pkgdir/usr/bin/gomu"
}