summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-05-08 09:46:28 +0300
committerAdrian Perez de Castro2020-05-08 09:49:54 +0300
commit38cc9c0de3bf71ee2d090ec7f342bfaa41f9b194 (patch)
tree20f4c18bd2218a996c726eb1c21528c59e7df5d8 /PKGBUILD
parentc6ba4da0b17b81aff5bee6456daec04cd33ae68c (diff)
downloadaur-38cc9c0de3bf71ee2d090ec7f342bfaa41f9b194.tar.gz
Add libolm dependency, remove prepare() hacks, properly quote $LDFLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a3a1f9acfbf..6b2c0b11a31b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,18 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=gomuks-git
pkgdesc='A terminal based Matrix client written in Go'
-pkgver=0.r339
+pkgver=0.r485
pkgrel=1
url='https://github.com/tulir/gomuks'
license=(GPL3)
arch=(x86_64 i686)
-depends=(glibc)
+depends=(libolm)
makedepends=(go-pie git)
provides=("${pkgname%-git}")
conflicts=("${provides[@]}")
source=("${pkgname}::git+${url}")
sha512sums=(SKIP)
-prepare () {
- cd "${pkgname}"
-
- # The Go modules index has some replacements to use locally checked
- # out modules; so remove those to make sure "go build" below will
- # ensure that the correct version is always fetched.
- sed -i -e '/^replace\s/d' go.mod
-
- # Fix a build failure
- go mod edit \
- -replace=gopkg.in/russross/blackfriday.v2@v2.0.1=github.com/russross/blackfriday/v2@v2.0.1
-}
-
pkgver () {
cd "${pkgname}"
echo "0.r$(git rev-list --count HEAD)"
@@ -34,10 +21,10 @@ pkgver () {
build () {
cd "${pkgname}"
local curdir=$(pwd)
- go build \
+ go build -v \
-gcflags "all=-trimpath=${curdir}" \
-asmflags "all=-trimpath=${curdir}" \
- -ldflags "-extldflags ${LDFLAGS}" \
+ -ldflags "-extldflags '${LDFLAGS}'" \
.
}