summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgituser2022-04-13 22:03:56 +0200
committergituser2022-04-13 22:03:56 +0200
commit20b3a0ac4192a759eaf4dc6ca3a54c91faa45ca3 (patch)
tree66b02a87037bf923892aeebaa0cd93d7cb0c1f00 /PKGBUILD
parent26904973a70aee4335a41287c65fcd335b9c4fc7 (diff)
downloadaur-20b3a0ac4192a759eaf4dc6ca3a54c91faa45ca3.tar.gz
try to fix install with custom kernels
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 597f6a105e7b..9fd504198aeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,11 @@
_pkgbase=goodix-gpdwin3
pkgname=${_pkgbase}-dkms
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Goodix touchscreen driver hack for GPD WIN3"
arch=('any')
license=('GPL2')
depends=('dkms')
-install=${pkgname}.install
source=(
"goodix.c"
"goodix.h"
@@ -20,14 +19,20 @@ source=(
md5sums=('6ef1b9c306d7996e7bfdb9cc50677f81'
'7543431323fd4a1efb2d381b69886ef9'
'616b595d278b52a265156c2fa68a740c'
- '5861e444eb6ba83d44a3c746f04e9a04'
- '7b0228ff533f0a8e63dc962621e0d97e'
+ 'f514c2a1d6de0f50ea5ebc112447ff7d'
+ '53d0b9c5ba6ba5457fd65ed901323360'
'1505740dffca34d8119f3798a0624ebc')
package() {
cd "$srcdir"
- local install_dir="${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ local install_dir="${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
install -Dm644 dkms.conf "${install_dir}/dkms.conf"
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${install_dir}"/dkms.conf
+
install -Dm644 goodix.c "${install_dir}/goodix.c"
install -Dm644 goodix.h "${install_dir}/goodix.h"
install -Dm644 goodix_fwupload.c "${install_dir}/goodix_fwupload.c"