diff options
author | zxp19821005 | 2024-02-06 17:44:02 +0800 |
---|---|---|
committer | zxp19821005 | 2024-02-06 17:44:02 +0800 |
commit | 586c32d3eeca2fddc6782e9da7d70c5e3dbf15e6 (patch) | |
tree | c398f9b4e5d6c1502f5f9ae7a9823ab8e12ea6ca /PKGBUILD | |
parent | 151351576d3ec2d7a2bf5851c0117ae0e09195a9 (diff) | |
download | aur-586c32d3eeca2fddc6782e9da7d70c5e3dbf15e6.tar.gz |
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 16 |
1 files changed, 9 insertions, 7 deletions
@@ -2,9 +2,9 @@ pkgname=google-calender-widget pkgver=1.1.3 _electronversion=25 -pkgrel=1 +pkgrel=2 pkgdesc="An unofficial google calendar desktop widget for Windows, Mac and Linux" -arch=('x86_64') +arch=('any') url="https://github.com/p32929/google-calender-widget" license=('MIT') conflicts=("${pkgname}") @@ -22,27 +22,29 @@ source=( "${pkgname}.sh" ) sha256sums=('SKIP' - '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf') + '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014') build() { sed -e "s|@electronversion@|${_electronversion}|" \ -e "s|@appname@|${pkgname}|g" \ - -e "s|@appasar@|app.asar|g" \ + -e "s|@runname@|app.asar|g" \ -i "${srcdir}/${pkgname}.sh" - gendesk -q -f -n --categories "Utility" --name "${pkgname}" --exec "${pkgname}" + gendesk -q -f -n --categories "Utility" --name "${pkgname}" --exec "${pkgname} %U" cd "${srcdir}/${pkgname}.git" export npm_config_build_from_source=true export npm_config_cache="${srcdir}/.npm_cache" export ELECTRON_SKIP_BINARY_DOWNLOAD=1 export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')" + export npm_config_target="${SYSTEM_ELECTRON_VERSION}" export ELECTRONVERSION="${_electronversion}" + HOME="${srcdir}/.electron-gyp" sed "5s|// ||g;5s|!==|==|g;6s|const|// const|g;s|icon.ico|icon.png|g" -i index.js npm install npm run dist:linux } package() { install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}" - install -Dm644 "${srcdir}/${pkgname}.git/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname}" - install -Dm644 "${srcdir}/${pkgname}.git/dist/linux-unpacked/resources/"{icon.png,styles.css} -t "${pkgdir}/usr/lib/${pkgname}/resources" + install -Dm644 "${srcdir}/${pkgname}.git/dist/linux-"*/resources/app.asar -t "${pkgdir}/usr/lib/${pkgname}" + install -Dm644 "${srcdir}/${pkgname}.git/dist/linux-"*/resources/{icon.png,styles.css} -t "${pkgdir}/usr/lib/${pkgname}/resources" install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications" install -Dm644 "${srcdir}/${pkgname}.git/resources/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png" install -Dm644 "${srcdir}/${pkgname}.git/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}" |