aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPascal Ronecker2024-01-06 19:20:22 +0100
committerPascal Ronecker2024-01-06 19:20:22 +0100
commit2ff056eca3492a4daf255e826113b552e6dd823f (patch)
treedd80e136b2bb4f85edfdb3bc4040945af72cbb0b /PKGBUILD
parentfac2b7203f879dd14368505427c57066238b6090 (diff)
downloadaur-2ff056eca3492a4daf255e826113b552e6dd823f.tar.gz
new package fix 5.27.23-6 with working symlink
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1f41e55c96e..8bacd6f3298c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Squalou <squalou.jenkins [at] gmail [dot] com>
pkgname=google-chat-linux-bin
pkgver=5.27.23
-pkgrel=5
+pkgrel=6
pkgdesc="Unofficial electron-based desktop client for Google Chat, electron included"
arch=('x86_64' 'i686')
url="https://github.com/squalou/google-chat-linux.git"
@@ -9,13 +9,14 @@ license=('WTFPL')
makedepends=('nodejs' 'npm' 'xz' 'binutils')
depends=('xdg-desktop-portal')
conflicts=('google-chat-linux-electron7-git')
+install="${pkgname}.install"
appname="${pkgname%-bin}"
[[ $CARCH == 'x86_64' ]] && _arch='x64' || _arch='ia32'
source=("https://github.com/squalou/${appname}/releases/download/${pkgver}-${pkgrel}/${appname}_${pkgver}-${pkgrel}_amd64.deb")
-sha512sums=('ce49bfdd42ee279c2ee81bfcfb33234ddec7d816fd0cd323e53c844d508e31ae445e5229c5007590420a0ea1bcb4f8cf8fd85d986ae58711841b1a4c2ed45806')
+sha512sums=('c592eb19ab3d46ae844a43d0e276fed5775ca93571679fd8da6ebd3edeb6e2cfe503c520c2224b38ca34e61d45efd76e0d6e4451f1d0cb3aeda60d229db1ce68')
build() {
ar x "${appname}_${pkgver}-${pkgrel}_amd64.deb"
@@ -25,7 +26,5 @@ build() {
package() {
mv "${srcdir}/usr" "${pkgdir}/usr"
mv "${srcdir}/opt" "${pkgdir}/opt"
- mkdir -p "${pkgdir}/usr/bin"
- ln -s "${pkgdir}/opt/${appname}/${appname}" "${pkgdir}/usr/bin/${appname}"
}