summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Denhartog2019-04-10 16:38:08 -0700
committerBenjamin Denhartog2019-04-10 16:38:08 -0700
commit2fbc42fcf44c4b7180d69f08611e45d7066f9209 (patch)
tree7326ed2bab3d21413e35c0ab6f375b5603ef0bab /PKGBUILD
parent876bbdfbdbfc0a5fbf394821dd354ad97deb4391 (diff)
downloadaur-2fbc42fcf44c4b7180d69f08611e45d7066f9209.tar.gz
new release: google-cloud-sdk 241.0.0-2
remove redundant _additional_components variable the --additional-components parameter seems to be ignored by bootstrapping/install.py now, perhaps due to an upstream change that now adheres to the same rule for the "updater" which handles component installation via active usage on the command line (e.g. gcloud components install <foo>) -- that is, because the "updater" is disabled, users cannot install additional components via the command line, and now this setting is being adhered to by the bootstrapping/install.py script. this patch would also appear to remove the alpha and beta components, however, these are now bundled in the for-packagers package by default. this behavior was previously unknown, so we should pay attention to it in the future.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 787fcb56b890..6ae8dce35475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname="google-cloud-sdk"
pkgver=241.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq."
url="https://cloud.google.com/sdk/"
license=("Apache")
@@ -64,8 +64,7 @@ package() {
mkdir "${pkgdir}/opt"
cp -r "${srcdir}/${pkgname}" "${pkgdir}/opt"
- msg2 "Running bootstrapping script and adding additional components"
- _additional_components=(alpha beta)
+ msg2 "Running bootstrapping script"
# The Google code uses a _TraceAction() method which spams the screen even
# in "quiet" mode, we're throwing away output on purpose to keep it clean
@@ -75,7 +74,7 @@ package() {
--usage-reporting False \
--path-update False \
--bash-completion False \
- --additional-components "${_additional_components[@]}" \
+ --additional-components "" \
1 > /dev/null
msg2 "Cleaning up artifacts of the bootstrap script"