summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-01-23 18:55:54 -0800
committerBenjamin Denhartog2020-01-23 20:41:30 -0800
commit8a9eff646c7a885158fde7e94da64e4ce3333763 (patch)
tree736674e9fb84f0bfb48d88ae210314d6100d7b1f /PKGBUILD
parent61792605df1402e970883ef1900a111d2e0c4155 (diff)
downloadaur-8a9eff646c7a885158fde7e94da64e4ce3333763.tar.gz
fix: add patch file to avoid SyntaxWarning when executing console_io.py
This patch adds a patch file to the package that fixes an erroneous usage of the 'is' operator with a literal (string) in lib/googlecloudsdk/core/console/console_io.py. This has been reported upstream. refs https://issuetracker.google.com/issues/147702239
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cea8190c351..badec599fee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname="google-cloud-sdk"
pkgver=276.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq."
url="https://cloud.google.com/sdk/"
license=("Apache")
@@ -20,15 +20,26 @@ options=('!strip' 'staticlibs')
source=(
"https://dl.google.com/dl/cloudsdk/release/downloads/for_packagers/linux/${pkgname}_${pkgver}.orig.tar.gz"
"google-cloud-sdk.sh"
+ "0001-fix-console-io-syntax-warning.patch"
)
sha256sums=('ad3d711e372fdcef141106d33e150aee4922a88c76484798a40b48a2fc779c3c'
- 'a54f88947a2593fae4aa8f65e42de4ad735583ae743735305c0f36710a794295')
+ 'a54f88947a2593fae4aa8f65e42de4ad735583ae743735305c0f36710a794295'
+ 'b3faeb3af2922510048d12063fa215610f12879f5cc9f8b78786c7d9f2957c70')
+
+prepare() {
+ cd "$pkgname"
+
+ for f in ./../*.patch; do
+ patch -p1 -i $f > /dev/null 2>&1 || ( echo "failed to apply patch: $(basename $f)" && exit 1 )
+ done
+}
package() {
echo "Copying core SDK components"
mkdir "${pkgdir}/opt"
cp -r "${srcdir}/${pkgname}" "${pkgdir}/opt"
+
echo "Running bootstrapping script"
# The Google code uses a _TraceAction() method which spams the screen even