summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Denhartog2021-12-13 09:41:48 -0700
committerBenjamin Denhartog2021-12-13 10:07:56 -0700
commit8f9a02c60de54a635a7ef61d6cf99ed1382fa928 (patch)
treea1882746862bb011387520843964be625a61121a /PKGBUILD
parent9a10e2845be5ab37616c81e3956071676ea3213f (diff)
downloadaur-8f9a02c60de54a635a7ef61d6cf99ed1382fa928.tar.gz
fix: add patch for collections.abc import error
python 3.10 was promoted to community, which causes an error when invoking google-cloud-sdk due to various imports which do not account for the difference between the python2 and python3 library change (various symbols from the root of the `collections` library were moved under `collections.abc`). Closes: sudoforge/pkgbuilds#50 Change-Id: I9cc5fe48d2a6124a0c86515cdcb9b82c325ca5b5 GitOrigin-RevId: a5e6d2808458b8e1b6e54a07b77103f1b81d0eb0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbb1377fbcbf..b31f734696c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname="google-cloud-sdk"
pkgver=366.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A set of command-line tools for the Google Cloud Platform. Includes gcloud (with beta and alpha commands), gsutil, and bq."
url="https://cloud.google.com/sdk/"
license=("Apache")
@@ -27,12 +27,14 @@ source=(
"0001-set-python2-for-dev-appserver-py.patch"
"0002-set-python2-for-endpointscfg-py.patch"
"0003-add-compdef-to-zsh-completion.patch"
+ "0004-collections-abc.patch"
)
sha256sums=('32a2d179539854a27ce7c203f9ba8a3ac5c346d99ca2565b8dad6e9645d1ac12'
'a54f88947a2593fae4aa8f65e42de4ad735583ae743735305c0f36710a794295'
'62ec7f56e09168d375823e9e99fcdcfbf40b0fffdd75f35cf91122c5902c82e9'
'ff6065ce2e54ac654605bd5fe554313b1d0def2c31ce56ff39429098dd1e39fe'
- '4694f5191ceea7cf8076861ce5790ba9e809023da278b0f6ed862b9611e5aa93')
+ '4694f5191ceea7cf8076861ce5790ba9e809023da278b0f6ed862b9611e5aa93'
+ '48545d175e3242cadd198920ee23919b4c8a2ff7f222e1668bc13c9b19e8a103')
prepare() {
cd "${srcdir}/${pkgname}"