summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTroy Engel2016-09-04 09:15:05 -0500
committerTroy Engel2016-09-04 09:15:05 -0500
commited8ce4ea9af40071811f9c744044cb2700ce566b (patch)
treed5aaac0cf841eee50ffe25d090a73d8da8e2cfbf /PKGBUILD
parent226b9b43379ece0a1730bb7466e2f4dc282853f9 (diff)
downloadaur-ed8ce4ea9af40071811f9c744044cb2700ce566b.tar.gz
add python2-crcmod optdep, remove symlink conflict
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9011c0ba161..82232574484f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname="google-cloud-sdk"
pkgver=124.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Contains tools and libraries that enable you to easily create and manage resources on Google Cloud Platform"
url="https://cloud.google.com/sdk/"
license=("Apache")
@@ -14,7 +14,8 @@ depends=('python2')
makedepends=('python2')
optdepends=('go: for Go version of App Engine'
'java-environment: for Java version of App Engine'
- 'php: for PHP version of App Engine')
+ 'php: for PHP version of App Engine'
+ 'python2-crcmod: verify the integrity of object contents')
options=('!strip' 'staticlibs')
# 64bit
@@ -85,6 +86,8 @@ package() {
"/opt/$pkgname/bin/%f\n" | xargs ln -st "$pkgdir/usr/bin"
# this conflicts with google-appengine-python
rm -f "$pkgdir/usr/bin/dev_appserver.py"
+ # this conflicts with google-appengine-python-php
+ rm -f "$pkgdir/usr/bin/endpointscfg.py"
# The tarball is rather sloppy with it's file permissions
msg2 "Fixing file permissions"