summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenzo Castelli2019-08-18 18:30:36 -0700
committerLorenzo Castelli2019-08-18 21:28:48 -0700
commit513dfde637b95a013aac998a726803b9bfdd475f (patch)
tree04a97d9a4b6c32b69e816358aaf3dd9f2e64536c /PKGBUILD
parent5ac2ff6570710a75297898f2a898b37fb7f48cdc (diff)
downloadaur-513dfde637b95a013aac998a726803b9bfdd475f.tar.gz
Updates package to version 20190801.
The new version adds some missing soname links. For updating it might be necessary to run the following command: sudo pacman -Syu --overwrite \ "/usr/lib/libnss_oslogin.so.2,/usr/lib/libnss_cache_oslogin.so.2"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac2e1a1a26c7..f7828ad19069 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,14 +16,14 @@
# Maintainer: Samuel Littley <samuellittley@google.com>
pkgname=('google-compute-engine' 'google-compute-engine-oslogin')
-pkgver=20190522
+pkgver=20190801
pkgrel=1
arch=('any' 'x86_64')
url='https://github.com/GoogleCloudPlatform/compute-image-packages'
license=('Apache')
makedepends=('curl' 'json-c' 'pam' 'python-boto' 'python-distro' 'python-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/compute-image-packages/archive/$pkgver.tar.gz")
-sha256sums=('8cfb338c3c768ea7e76e479728a1438b2f10b0df13bddd70c9fbcbfc1273efd6')
+sha256sums=('495ce6e44034b26cbcf619aeebe2cb83334ee801b2130ba2f20d4468483d3ce8')
build() {
cd "compute-image-packages-$pkgver/packages"
@@ -52,8 +52,7 @@ package_google-compute-engine() {
install -m644 -Dt "$pkgdir/usr/lib/systemd/system/" lib/systemd/system/*
install -m644 -Dt "$pkgdir/usr/lib/udev/rules.d" lib/udev/rules.d/*
install -m755 -Dt "$pkgdir/usr/bin" usr/bin/*
- # Use cp to install symbolic links.
- cp -d etc/dhcp/dhclient-exit-hooks "$pkgdir/etc/dhclient-exit-hooks"
+ ln -s /usr/bin/google_set_hostname "$pkgdir/etc/dhclient-exit-hooks"
popd
}