summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTheCynicalLiger2020-06-20 17:12:59 +0100
committerTheCynicalLiger2020-06-20 17:12:59 +0100
commit18bd1701773a92362d04cff7e4965283f4b8c5ab (patch)
tree983e23d337215e257e2a0c476ce1c46d0bcecae4 /PKGBUILD
parent5b2db70e615604dfd5257f11d0f421b8a07ca57a (diff)
downloadaur-google-earth.tar.gz
Updated Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD111
1 files changed, 63 insertions, 48 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4a9d5b28bb8..29cc9aee620b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,71 @@
-# Maintainer: Det <nimetonmaili g-mail>
-# Contributors: 458italia, Madek, Berseker, Syr
-# Check the latest version with:
-# $ curl -sL https://dl.google.com/linux/earth/deb/dists/stable/main/binary-amd64/Packages | grep -Pom1 "Version: \K[^-]*"
+# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+# Contributor: Daniel Bermond <dbermond@archlinux.org>
+# Contributor: Det <nimetonmaili g-mail>
+
+# check the latest version with:
+# $ curl -sL https://dl.google.com/linux/earth/deb/dists/stable/main/binary-amd64/Packages | grep -Pom1 'Version: \K[^-]*'
pkgname=google-earth
-pkgver=7.1.8.3036
-pkgrel=1
-pkgdesc="Semi-legacy 3D interface to explore the globe, terrain, streets, buildings and other planets"
+pkgver=7.3.3.7721
+pkgrel=2
+pkgdesc='3D interface to explore the globe, terrain, streets, buildings and other planets (Pro version)'
arch=('x86_64')
-url="https://www.google.com/earth/index.html"
-license=('custom:earth')
-depends=('glu' 'hicolor-icon-theme' 'ld-lsb>=3-5' 'libsm' 'libxrender' 'nss'
- 'libproxy' 'gst-plugins-base-libs' 'libxi' 'fontconfig' 'alsa-lib' 'libcups')
+url='https://www.google.com/earth/'
+license=('custom')
+depends=('glu' 'hicolor-icon-theme' 'libsm' 'libxrender' 'libproxy'
+ 'gst-plugins-base-libs' 'libxi' 'fontconfig' 'alsa-lib' 'libcups'
+ 'desktop-file-utils')
optdepends=('catalyst-utils: For AMD Catalyst'
'nvidia-utils: For the NVIDIA driver')
-options=('!emptydirs')
-install=$pkgname.install
-source=("google-earth-stable_${pkgver}_amd64.deb::https://dl.google.com/linux/earth/deb/pool/main/g/google-earth-stable/google-earth-stable_7.1.8.3036-r0_amd64.deb"
- 'Google-Terms-of-Service.html::https://www.google.com/intl/ALL/policies/terms/index.html'
- 'Google-Earth-Additional-Terms-of-Service.html::https://www.google.com/help/terms_maps.html'
- 'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html::https://www.google.com/help/legalnotices_maps.html'
- 'Google-Privacy-Policy.html::https://www.google.com/intl/ALL/policies/privacy/index.html')
-md5sums=('77cb0eacde195c224767a77ccf54c8ef'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
-
-_instdir=/opt/google/earth/free/
+provides=('google-earth')
+options=('!strip' '!emptydirs')
+install="${pkgname}.install"
+source=("https://dl.google.com/linux/earth/deb/pool/main/g/google-earth-pro-stable/google-earth-pro-stable_${pkgver}-r0_amd64.deb"
+ 'Google-Terms-of-Service.html'::'https://www.google.com/intl/ALL/policies/terms/index.html'
+ 'Google-Earth-Additional-Terms-of-Service.html'::'https://www.google.com/help/terms_maps.html'
+ 'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html'::'https://www.google.com/help/legalnotices_maps.html'
+ 'Google-Privacy-Policy.html'::'https://www.google.com/intl/ALL/policies/privacy/index.html')
+noextract=("google-earth-pro-stable_${pkgver}-r0_amd64.deb")
+sha256sums=('db3f4b224426789ffb8d76a5f64126f8a2822bc42d30da162ac05d039047a152'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+_installdir='/opt/google/earth/pro'
+
+prepare() {
+ mkdir -p "${pkgname}-${pkgver}"
+ bsdtar -xf "google-earth-pro-stable_${pkgver}-r0_amd64.deb" -C "${pkgname}-${pkgver}"
+}
package() {
- msg2 "Extracting the data.tar.xz..."
- bsdtar -xf data.tar.xz -C "$pkgdir/"
-
- msg2 "Moving stuff in place..."
- # The .desktop
- mv "$pkgdir"/$_instdir/google-earth.desktop "$pkgdir"/usr/share/applications/
-
- # Icons
- for i in 16 22 24 32 48 64 128 256; do
- install -Dm644 "$pkgdir"/$_instdir/product_logo_$i.png \
- "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/google-earth.png
- done
-
- # Licenses
- for i in 'Google-Terms-of-Service.html' \
- 'Google-Earth-Additional-Terms-of-Service.html' \
- 'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html' \
- 'Google-Privacy-Policy.html'; do
- install -Dm644 $i "$pkgdir"/usr/share/licenses/$pkgname/$i
- done
-
- msg2 "Removing the Debian-intended cron job and duplicated images..."
- rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/$_instdir/product_logo_*.png
+ bsdtar -xf "${pkgname}-${pkgver}/data.tar.xz" -C "$pkgdir"
+
+ # desktop file
+ mv "${pkgdir}/${_installdir}/google-earth-pro.desktop" "${pkgdir}/usr/share/applications"
+
+ # icons
+ local _res
+ for _res in 16 22 24 32 48 64 128 256
+ do
+ install -D -m644 "${pkgdir}/${_installdir}/product_logo_${_res}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/google-earth-pro.png"
+ done
+
+ # remove the debian-intended cron job and duplicated images
+ rm -r "${pkgdir}/etc/cron.daily" "${pkgdir}/${_installdir}"/product_logo_*.png
+
+ # fix search
+ sed -i '/googleearth-bin/s/^/LC_NUMERIC=en_US.UTF-8 /' "${pkgdir}/${_installdir}/googleearth"
+
+ # licenses
+ local _file
+ for _file in 'Google-Terms-of-Service.html' \
+ 'Google-Earth-Additional-Terms-of-Service.html' \
+ 'Legal-Notices-for-Google-Earth-and-Google-Earth-APIs.html' \
+ 'Google-Privacy-Policy.html'
+ do
+ install -D -m644 "$_file" "${pkgdir}/usr/share/licenses/${pkgname}/${_file}"
+ done
}