summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2018-02-09 02:37:47 +0200
committerDet2018-02-09 02:37:47 +0200
commit8c7cb5760c43c1c16916e55b2ae2a07664b000c4 (patch)
tree570e001b9ffd9318797cc1693911b1f59aabf8b3 /PKGBUILD
parented72fba373e3d45ba3434c364e57028b99b0eb90 (diff)
downloadaur-8c7cb5760c43c1c16916e55b2ae2a07664b000c4.tar.gz
rm old workaround
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 0 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8096a9b2f6fc..42c556dfcdbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,6 @@
# Check the latest version with:
# $ curl -sL https://dl.google.com/linux/earth/deb/dists/stable/main/binary-amd64/Packages | grep -Pom1 "Version: \K[^-]*"
-# Attempt to fix crashes and blank Panoramio: "1" to enable.
-# - http://forums.fedoraforum.org/showthread.php?p=1678303#post1678303
-_attempt_fix=0
-
pkgname=google-earth
pkgver=7.1.8.3036
pkgrel=1
@@ -16,7 +12,6 @@ url="https://www.google.com/earth/index.html"
license=('custom:earth')
depends=('glu' 'hicolor-icon-theme' 'ld-lsb>=3-5' 'libsm' 'libxrender' 'nss'
'libproxy' 'gst-plugins-base-libs' 'libxi' 'fontconfig' 'alsa-lib' 'libcups')
-[[ $_attempt_fix = 1 ]] && depends+=('freeimage' 'libpng15' 'qtwebkit')
optdepends=('catalyst-utils: For AMD Catalyst'
'nvidia-utils: For the NVIDIA driver')
options=('!emptydirs')
@@ -38,13 +33,6 @@ md5sums=('77cb0eacde195c224767a77ccf54c8ef'
_instdir=/opt/google/earth/free/
-# Build the baifaao.so
-if [[ $_attempt_fix = 1 ]]; then
- build() {
- gcc -I /usr/include/qt4/ -O3 -fPIC --shared baifaao.cpp -o baifaao.so
- }
-fi
-
package() {
msg2 "Extracting the data.tar.xz..."
bsdtar -xf data.tar.xz -C "$pkgdir/"
@@ -69,16 +57,4 @@ package() {
msg2 "Removing the Debian-intended cron job and duplicated images..."
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/$_instdir/product_logo_*.png
-
- if [[ $_attempt_fix = 1 ]]; then
- msg2 "Attempting a fix on Panoramio and certain crashes..."
- # Install baifaao.so
- install -m755 baifaao.so "$pkgdir"/$_instdir/
-
- # Preload it
- install -m755 googleearth.sh "$pkgdir"/$_instdir/googleearth
-
- # Remove the old, bundled Qt libs
- rm "$pkgdir"/$_instdir/libQt*
- fi
}