summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2016-02-21 20:22:58 +0200
committerDet2016-02-21 20:22:58 +0200
commit9568db0b353f5b80a33da6fffda08ecec4e9a01f (patch)
tree53ebe90480b8b122402e1cab5e46bce69c22ab8b /PKGBUILD
parent30405d8475fe8b91ec357c86c4d1156ff8717832 (diff)
downloadaur-9568db0b353f5b80a33da6fffda08ecec4e9a01f.tar.gz
New ones of them licenses
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fcaaa48f753..e4727807c346 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,9 +71,16 @@ package() {
install -Dm644 "$pkgdir"/$_instdir/product_logo_$i.png "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/google-earth.png
done
- # The license (too many different ones to do this in "source=()")
- install -d "$pkgdir"/usr/share/licenses/google-earth/
- curl -Ls ${url/i*}/license.html -o "$pkgdir"/usr/share/licenses/google-earth/license.html
+ # Licenses (different countries redirect to different ones)
+ install -d "$pkgdir"/usr/share/licenses/$pkgname/
+ curl -Ls https://www.google.com/intl/ALL/policies/terms/index.html \
+ -o "$pkgdir/usr/share/licenses/$pkgname/Google Terms of Service.html"
+ curl -Ls https://www.google.com/help/terms_maps.html \
+ -o "$pkgdir/usr/share/licenses/$pkgname/Google Earth Additional Terms of Service.html"
+ curl -Ls https://www.google.com/help/legalnotices_maps.html \
+ -o "$pkgdir/usr/share/licenses/$pkgname/Legal Notices for Google Earth and Google Earth APIs.html"
+ curl -Ls https://www.google.com/intl/ALL/policies/privacy/index.html \
+ -o "$pkgdir/usr/share/licenses/$pkgname/Google Privacy Policy.html"
msg2 "Removing the Debian-intended cron job and duplicated images..."
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/$_instdir/product_logo_*.png