summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Westover2021-07-15 01:43:28 -0400
committerBen Westover2021-07-15 01:43:28 -0400
commit3330dda6466174075cb412f5a1ebb735c7bf1bcf (patch)
tree6d7c18451fcc00faee9a1cde9142649b2c21a486 /PKGBUILD
parent571420041ce5c4566b7c43eb71bc8da29df4bb20 (diff)
downloadaur-3330dda6466174075cb412f5a1ebb735c7bf1bcf.tar.gz
Change architecture detection logic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b5c48dbf337..67a7b83cf43f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,13 +14,13 @@ sha256sums=('3c938c748fbef4cdd72e638b26aa35f3e2da8045a0c5490ede8b6ef5603f1b2c'
'6909e255521af089883f18740fc91c7743897c99d4ece0784b969cea5bc480ae')
build() {
- if [ `uname -m` = "x86_64" ]; then
+ if [ "$CARCH" = "x86_64" ]; then
_NFARCH='x64'
- elif [ `uname -m` = "i686" ] || [ `uname -m` = "pentium4" ]; then
+ elif [ "$CARCH" = "i686" ] || [ "$CARCH" = "pentium4" ]; then
_NFARCH='ia32'
- elif [ `uname -m` = "aarch64" ]; then
+ elif [ "$CARCH" = "aarch64" ]; then
_NFARCH='arm64'
- elif [ `uname -m` = "armv7l" ]; then
+ elif [ "$CARCH" = "armv7h" ]; then
_NFARCH='armv7l'
else
echo "Unsupported architecture. Aborting"