summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMickael Foucaux2017-07-03 00:50:37 +0100
committerMickael Foucaux2017-07-03 00:50:37 +0100
commit025e1053fa49b8350226804cd429c9223e8a50be (patch)
tree3a0649282c118988aeeb24ff1e0957ef7382d9ef /PKGBUILD
downloadaur-025e1053fa49b8350226804cd429c9223e8a50be.tar.gz
Initial AUR release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b16d96b90cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mickael Foucaux <mickael.foucaux@gmail.com>
+pkgname=gopro-tools-git
+pkgver=1.0.r0.g5c6bd4e
+pkgrel=1
+pkgdesc="Tools for post production with GoPro cameras"
+arch=('any')
+url="https://github.com/KonradIT/gopro-linux"
+license=('GPL3')
+groups=('gopro-git')
+conflicts=('gopro-tools')
+depends=('mencoder' 'ffmpeg' 'imagemagick')
+source=('git+https://github.com/KonradIT/gopro-linux.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd gopro-linux
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -D -m755 "$srcdir/gopro-linux/gopro" "$pkgdir/usr/bin/gopro"
+}