summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Ascher2016-07-17 23:24:37 +0200
committerThomas Ascher2016-07-17 23:24:37 +0200
commitf077a863025d8f694afe7d0b63d7892e1dc9eef2 (patch)
tree8fc28595480dc0b025b35636972b4987590885f4 /PKGBUILD
downloadaur-f077a863025d8f694afe7d0b63d7892e1dc9eef2.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8b3b7897453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
+# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+pkgname=gorm
+pkgrel=1
+pkgver=1.2.20
+pkgdesc="GNUstep's easy-to-use interface designer."
+arch=('i686' 'x86_64')
+url="http://www.gnustep.org/experience/Gorm.html"
+license=('GPL')
+install=$pkgname.install
+depends=('gnustep-base'
+ 'gnustep-gui')
+makedepends=('gcc-objc'
+ 'gnustep-make')
+source=("ftp://ftp.gnustep.org/pub/gnustep/dev-apps/$pkgname-$pkgver.tar.gz"
+ "gorm.install")
+sha256sums=('1428bee51999e1915017a1d283a6ad73a94cabdddb7a0d5ad0e9f79bec92d6c0'
+ 'f703f8de14eb277dc72cc837086fbd55f5d772049a44200686c8ae76348f6614')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/Gorm.app/Resources/Gorm.desktop" \
+ "$pkgdir/usr/share/applications/Gorm.desktop"
+}