summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSauyon Lee2016-01-25 03:01:11 +0000
committerSauyon Lee2016-01-25 03:58:22 +0000
commit5e802f6a0bb029c7bf28bc8ccbc752a8e88d659c (patch)
tree188f2b19c11324b856404a4edfc597697a3e4543 /PKGBUILD
downloadaur-5e802f6a0bb029c7bf28bc8ccbc752a8e88d659c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68ece6a86750
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sauyon Lee <sauyon@satori>
+pkgname=gosh
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="interactive shell for Golang"
+arch=('i686' 'x86_64')
+url="https://github.com/mkouhei/gosh"
+license=('GPL')
+depends=('go' 'goimports-git')
+makedepends=()
+source=("$pkgname-$pkgver::https://github.com/mkouhei/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('fff34e4fcd165f937df61233fbc169f6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ go build
+}
+
+# this is broken for some reason
+#check() {
+# cd "$srcdir/$pkgname-$pkgver"
+#
+# go test
+#}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 $pkgname-$pkgver "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: