summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraligator2021-05-07 23:28:49 +0200
committeraligator2021-05-07 23:28:49 +0200
commit48cb4ac161684ab45faa8bc23e6b18575cfc8ab5 (patch)
tree045fc4cef04ec2bb7ac4d00ba44f9de236e164a4 /PKGBUILD
parent9b0b02353fb77c6065c8276aa669780e710dc390 (diff)
downloadaur-48cb4ac161684ab45faa8bc23e6b18575cfc8ab5.tar.gz
Fix Go flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70782577c30a..3145f530efcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=GoSlice
pkgver=0.3.9
# Hash of the commit to pass it as BUILD version (as it's not retrievable without git)
_pkgverhash=d5c7a2e
-pkgrel=1
+pkgrel=2
pkgdesc="An experimental slicer for 3d printing written in Go."
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/aligator/GoSlice"
@@ -20,7 +20,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
cd "$srcdir/$_pkgname-$pkgver"
make VERSION=$pkgver BUILD=$pkgverhash DESTDIR="$pkgdir" PREFIX="/usr" build