summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2015-06-08 23:16:23 +0800
committerwenLiangcan2015-06-08 23:16:23 +0800
commitadb7d3cb3190d96cde0baa1e2e08fcb621dafcef (patch)
tree1c317abf0ebb2deb0c06bc20799dc63cc685db2c /PKGBUILD
downloadaur-adb7d3cb3190d96cde0baa1e2e08fcb621dafcef.tar.gz
gotags-git 20150322-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fdee2c261a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+pkgname=gotags-git
+_pkgname=gotags
+pkgver=20150322
+pkgrel=1
+pkgdesc="ctags-compatible tag generator for Go."
+arch=("any")
+url="https://github.com/jstemmer/gotags"
+license=('Other')
+makedepends=('git' 'go')
+depends=()
+provides=('gotags')
+source=("${_pkgname}"::'git://github.com/jstemmer/gotags.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+build() {
+ cd "${_pkgname}"
+ GOPATH=${srcdir} go build -o "${_pkgname}"
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+}