summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordesbma2024-03-03 21:48:45 +0100
committerdesbma2024-03-03 21:48:50 +0100
commit97795e64e54940082d31dff0873f9b3d9307a7eb (patch)
tree3038c52799194c38561c505d640a5c44dcb4d66d /PKGBUILD
parentf2290323f425a39b4db37fda8b0f51b3b95200e0 (diff)
downloadaur-97795e64e54940082d31dff0873f9b3d9307a7eb.tar.gz
upgpkg: gotify-desktop 1.3.4-2
gotify-desktop: add PNG icons See https://github.com/desbma/gotify-desktop/issues/15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d524b047ecd..e00621f6131f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# shellcheck disable=SC2034,SC2148,SC2154,SC2164
pkgname=gotify-desktop
pkgver=1.3.4
-pkgrel=1
+pkgrel=2
pkgdesc='Small Gotify daemon to send messages as desktop notifications '
arch=('aarch64' 'x86_64')
url="https://github.com/desbma/${pkgname}"
license=('GPL3')
depends=('gcc-libs' 'openssl')
-makedepends=('cargo' 'scour')
+makedepends=('cargo' 'librsvg' 'oxipng' 'scour')
_logo_commit='25c1d2c08894fcb0ed39c36a2816316a161c0e57'
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/desbma/${pkgname}/archive/${pkgver}.tar.gz"
"https://github.com/gotify/logo/archive/${_logo_commit}.tar.gz")
@@ -39,7 +39,16 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
+
install -Dm 755 -t "${pkgdir}/usr/bin" ./target/release/${pkgname}
+
install -Dm 644 -t "${pkgdir}/usr/share/applications" ./desktop/${pkgname}.desktop
+
install -Dm 644 "${srcdir}/logo-${_logo_commit}/gotify-logo-small-minified.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ for size in {16,22,24,32,48,64,128,256,512}
+ do
+ dest="${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
+ mkdir -p "${dest}"
+ rsvg-convert -w "${size}" -h "${size}" -f png "${srcdir}/logo-${_logo_commit}/gotify-logo-small.svg" | oxipng -o2 -a -Z --out "${dest}/${pkgname}.png" -
+ done
}