summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJannis Mattheis2020-03-07 20:45:45 +0100
committerml2020-03-08 14:10:53 +0100
commitab4d50b63c0fb89b726a11d7d57bf436b224c610 (patch)
treeba33ca23891e3e9a764f5dc9b18ad3f03eed7cd8 /PKGBUILD
parentd7fccce26d323bdfe2ff2b0225190092b2e05e14 (diff)
downloadaur-ab4d50b63c0fb89b726a11d7d57bf436b224c610.tar.gz
Add build instructions for the UI
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 660a9321b541..045a512bc415 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='A simple server for sending and receiving messages in real-time per Web
arch=('x86_64' 'i686' 'aarch64' 'armv7')
url='https://gotify.net/'
license=('MIT')
-makedepends=('git' 'go')
+makedepends=('git' 'go' 'yarn')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/gotify/server/archive/v${pkgver}.tar.gz"
'sysusers.d'
@@ -24,6 +24,12 @@ sha256sums=('986125b92192e404a2f3af5db510d2d651c6301d218cbb66edd6013f8e8153b0'
build() {
cd "server-$pkgver"
+ (
+ cd ui
+ yarn --non-interactive --frozen-lockfile
+ yarn --non-interactive --frozen-lockfile build
+ )
+ go run github.com/gobuffalo/packr/packr
local build_date=$(date "+%F-%T" -d "@${SOURCE_DATE_EPOCH}")
go build \
-o "$pkgname" \