summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2016-08-09 18:42:18 +0200
committerBalló György2016-08-09 18:42:18 +0200
commitbfc29a567e079aaa7804e3853272f99725d9787a (patch)
treed59248705b7428a9967d133055fb6a1eb7978da4 /PKGBUILD
downloadaur-bfc29a567e079aaa7804e3853272f99725d9787a.tar.gz
Add gotk3-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e535b252c46e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=gotk3-git
+pkgver=20160809
+pkgrel=1
+pkgdesc="Go bindings for GTK3"
+arch=('x86_64' 'i686')
+url="https://github.com/conformal/gotk3"
+license=('ISC')
+depends=('go' 'gtk3')
+makedepends=('git')
+conflicts=('gotk3')
+provides=('gotk3')
+options=('!strip' '!emptydirs')
+_gourl=github.com/conformal/gotk3
+
+build() {
+ GOPATH="$srcdir" go get -fix -v -x $_gourl/gtk
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/go"
+ cp -Rv --preserve=timestamps "$srcdir/"{src,pkg} "$pkgdir/usr/lib/go"
+ rm -r "$pkgdir/usr/lib/go/src/$_gourl/.git"
+ install -Dm644 "$srcdir/src/$_gourl/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ find "$pkgdir/usr/lib/go" \
+ -name ".*" -prune -exec rm -r '{}' \;
+}