summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2019-01-07 07:28:30 +0100
committerFabioLolix2019-01-07 07:28:30 +0100
commit075099a19185be74d9a148199c41a71b7a05002b (patch)
tree3af98ede9ecd7ac48e07ae7c114827768bf757b0 /PKGBUILD
parent485cd29d174f0acb105b44bd849df5f35f409936 (diff)
downloadaur-075099a19185be74d9a148199c41a71b7a05002b.tar.gz
v1.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0de04547fd9c..8cd485040328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Caleb Bassi <calebjbassi@gmail.com>
pkgname=gotop
-pkgver=1.6.0
+pkgver=1.7.1
pkgrel=1
pkgdesc='A terminal based graphical activity monitor inspired by gtop and vtop'
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -10,13 +10,25 @@ url="https://github.com/cjbassi/gotop"
license=(AGPL3)
makedepends=(go-pie git)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cjbassi/gotop/archive/${pkgver}.tar.gz")
-sha256sums=('c55ab94cb3f532cec1a060e4965451dc9e72443dfb4b07bb6579934d5cdb2a7d')
+sha256sums=('0041d36e664870d0b461b80bba4a2fb5120af1030230f09e3e9887a67c117363')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -m755 -d "$srcdir/go/src/github.com/cjbassi"
+ cp -a "$srcdir/$pkgname-$pkgver" "$srcdir/go/src/github.com/cjbassi/gotop"
+}
build() {
- cd "$pkgname-$pkgver"
- go build
+ cd "$srcdir/go/src/github.com/cjbassi/gotop"
+
+ export GOPATH="$srcdir/go"
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+
+ go get -v github.com/cjbassi/gotop
+ make dist/gotop
}
package() {
- install -Dm755 "$pkgname-$pkgver"/gotop $pkgdir/usr/bin/gotop
+ install -Dm755 "$srcdir"/go/bin/gotop "$pkgdir"/usr/bin/gotop
}