summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean E. Russell2020-03-06 19:05:25 -0600
committerSean E. Russell2020-03-06 19:05:25 -0600
commit0e5001a04dd82b1f41a54f7f494484a51c57369f (patch)
treef9787306170e414995134aadd8f689149b1d7b88 /PKGBUILD
parent4afdf7c96c1baf59654ac09bf721956579d497cd (diff)
downloadaur-0e5001a04dd82b1f41a54f7f494484a51c57369f.tar.gz
Updated to v3.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 512c315d44c8..1ed33b57616f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Caleb Bassi <calebjbassi@gmail.com>
pkgname=gotop
-pkgver=3.3.2
+pkgver=3.5.0
pkgrel=1
pkgdesc="A terminal based graphical activity monitor inspired by gtop and vtop"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -11,10 +11,11 @@ url="https://github.com/xxxserxxx/gotop"
license=(AGPL3)
makedepends=(go)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('80ff7c3cf89f0ebe97848b798dde466a6bb932b284a3330c7777d1968d77b36c')
+depends=("glibc")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ CGO_ENABLED=0
go build \
-gcflags "all=-trimpath=${PWD}" \
-asmflags "all=-trimpath=${PWD}" \
@@ -26,3 +27,4 @@ build() {
package() {
install -Dm755 "${srcdir}"/${pkgname}-${pkgver}/gotop "${pkgdir}"/usr/bin/gotop
}
+md5sums=('e340aa1cf7b98d61d23511367d026bcb')