summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Sever2021-09-24 18:24:25 +0300
committerYigit Sever2021-09-24 18:25:00 +0300
commit7a5c8b4b2e7ca16722c49c6c0abdb5c754fb5165 (patch)
tree6adf35dd30923a8ebfe731bd66eb3d19e223f250 /PKGBUILD
downloadaur-7a5c8b4b2e7ca16722c49c6c0abdb5c754fb5165.tar.gz
Initial commit v1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e80e62825b19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+
+pkgname='gourmand'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A recipe manager for desktop with the possibilities to import, organize, and tweak recipes"
+arch=('any')
+url="https://github.com/GourmandRecipeManager/gourmand"
+license=('GPL')
+depends=('python-gobject' 'gtk3' 'python-pyenchant' 'gst-python' 'python-pillow' 'python-sqlalchemy')
+makedepends=('python-pip')
+checkdepends=()
+optdepends=('python-beautifulsoup4: Webpage import plugin')
+provides=("${pkgname}")
+conflicts=('gourmet')
+source=("$pkgname-$pkgver-py3-none-any.whl::$url/releases/download/$pkgver/$pkgname-$pkgver-py3-none-any.whl")
+sha256sums=('9f1acf7098e62a8bca932ba43a9f1ee6b94978073824b96c5c1032fce23b12d4')
+
+package() {
+ # https://wiki.archlinux.org/title/Python_package_guidelines#pip
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+}
+# vim:set ts=2 sw=2 et: