summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2020-06-17 15:42:10 +0000
committerBalló György2020-06-17 15:42:10 +0000
commit735875cf34e2c0569593567ecb3dfaffe9e50b69 (patch)
treeef6c630d576c7173834c3dfb8ac41e061bd436b1 /PKGBUILD
parenta4f3f38c2d9bec43d9df462a8a62357286645a37 (diff)
downloadaur-735875cf34e2c0569593567ecb3dfaffe9e50b69.tar.gz
Use upstream resources cleanup the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 17 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20c5932d5b55..62d08976958c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,31 @@
# Maintainer: Tesx <tesfabpel@gmail.com>
+
pkgname=goxel
pkgver=0.10.6
pkgrel=1
-pkgdesc="Open Source 3D voxel editor for Mac, Windows and Linux."
-arch=('i686' 'x86_64')
-url="https://guillaumechereau.github.io/goxel/"
-license=('GPL3')
-groups=()
-makedepends=(scons pkg-config patch clang)
+pkgdesc="3D program that lets you create voxel volumes"
+arch=(x86_64)
+url="https://goxel.xyz/"
+license=(GPL3)
depends=(glfw gtk3)
-source=("https://github.com/guillaumechereau/$pkgname/archive/v$pkgver.tar.gz"
- 'goxel.desktop'
- 'goxel.png'
- 'werror.patch')
-sha256sums=('af57197910788131441a537cc658a3397448d90552a0fd3bfe9992635e9d64d8'
- '9b29df7405a9593396bc7ea810dc2871cce7c4ee474c1fa56d32f56c2ca2d921'
- 'f857497012b8518817e321ff8e1e9f108c8e18b638285702f2041f82769d2652'
- '24558e9430c95799041471bd8942eb8f02b62ecee033e08924939f4f7bbfdbd1')
+makedepends=(scons)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/guillaumechereau/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('af57197910788131441a537cc658a3397448d90552a0fd3bfe9992635e9d64d8')
prepare() {
- cd "$pkgname-$pkgver"
- patch < ../werror.patch
+ cd $pkgname-$pkgver
+ sed -i 's|scons mode=release|scons mode=release werror=n|
+ s|/share/applications/goxel.desktop|/share/applications/io.github.guillaumechereau.Goxel.desktop|
+ s|install -Dm744 goxel|install -Dm755 goxel|' Makefile
+ sed -i 's|\${SNAP}/icon.png|goxel|' snap/gui/goxel.desktop
}
build() {
- cd "$pkgname-$pkgver"
- make release
+ cd $pkgname-$pkgver
+ make release
}
package() {
- install -Dm644 goxel.desktop "$pkgdir/usr/share/applications/goxel.desktop"
- install -Dm644 goxel.png "$pkgdir/usr/share/icons/goxel.png"
-
- cd "$pkgname-$pkgver"
- install -Dm755 goxel "$pkgdir/usr/bin/goxel"
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" PREFIX=/usr install
}