aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortill busch2022-04-08 22:21:09 +0200
committerGitHub2022-04-08 22:21:09 +0200
commit3f093670ddae4b3e803cae7403a91c027dbb76b6 (patch)
treeb2900bc6340191087a0f048cc4694def292ab3c8 /PKGBUILD
parentde3ac8edace2bfe533f462ebe493f75cb1a3e6d1 (diff)
downloadaur-gpaste-git.tar.gz
Update PKGBUILD for meson
gpaste switched to meson in 2019. not sure if the build path should be under $pkgname or somewhere next to it. autostart is not installed anymore, bash and zsh completion files are installed to the right place. everything seems to work fine for me with these changes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 4 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73d4e4f82c96..0dd504487e1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,31 +23,17 @@ pkgver() {
}
prepare() {
- cd $pkgname
- NOCONFIGURE=1 ./autogen.sh
+ arch-meson "$pkgname" "$pkgname/build"
}
build() {
- cd $pkgname
- ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc \
- --enable-vala --enable-applet
- make
+ meson compile -C "$pkgname/build"
}
check () {
- cd $pkgname
- make check
+ meson test -C "$pkgname/build"
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
-
- install -Dm644 data/completions/gpaste-client \
- "$pkgdir/usr/share/bash-completion/completions/gpaste-client"
- install -Dm644 data/completions/_gpaste-client \
- "$pkgdir/usr/share/zsh/site-functions/_gpaste-client"
-
- # Don't autostart the applet, ever
- rm "$pkgdir/etc/xdg/autostart/org.gnome.GPaste.Applet.desktop"
+ meson install --destdir "$pkgdir" -C "$pkgname/build"
}