summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2021-05-29 03:38:12 +0300
committerorhun2021-05-29 03:38:12 +0300
commit8b7e35e6b6d29769ddae0505dc4b2c13349f0a59 (patch)
treec0fd6bf0e8cad148980938b04fa74e7dc1c2fe7c /PKGBUILD
downloadaur-8b7e35e6b6d29769ddae0505dc4b2c13349f0a59.tar.gz
Initial upload: gpg-tui-bin 0.1.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2a759134187
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=gpg-tui-bin
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A terminal user interface for GnuPG"
+arch=('x86_64')
+url="https://github.com/orhun/gpg-tui"
+license=('MIT')
+depends=('libx11' 'gpgme')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}")
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-$pkgver-x86_64-unknown-linux-gnu.tar.gz"{,.sig})
+sha512sums_x86_64=('390fd4d4454e116c9da63f4280a1e3aa73bab950323f8be19771faaf638872c259b9c354e71fcdf22b57ca705b2810e7263161cfe3ddb357fffc67760105365a'
+ 'SKIP')
+validpgpkeys=('14D49A4073C6899425D5315C1BC755D9FBD24068') # gpg-tui <gpg-tui@protonmail.com>
+
+package() {
+ cd "${pkgname%-bin}-$pkgver"
+ install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 "man/${pkgname%-bin}.1" -t "$pkgdir/usr/share/man/man1"
+ install -Dm 644 "completions/${pkgname%-bin}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-bin}"
+ install -Dm 644 "completions/${pkgname%-bin}.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/_${pkgname%-bin}" -t "${pkgdir}/usr/share/zsh/site-functions"
+}