summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBennett Piater2022-11-04 21:02:00 +0100
committerBennett Piater2022-11-04 21:02:00 +0100
commit4223394ea8fcea806fc0199b7123b4f544e61313 (patch)
tree7f1657facecde65e735b1d79b6a07ce768972ab9 /PKGBUILD
parent5cca1b18788057e608206bae07a3d43778f9a75d (diff)
downloadaur-gpgsync.tar.gz
upgpkg: gpgsync 0.3.6-2
use modern python packaging, per yochananmarqos
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56e1cacbec3b..50532a4cb870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
pkgname=gpgsync
pkgver=0.3.6
-pkgrel=1
-pkgdesc="A tool to let users always have up-to-date public keys for other members of their organization."
+pkgrel=2
+pkgdesc="Designed to let users always have up-to-date public keys for other members of their organization"
arch=('any')
-url="https://github.com/firstlookmedia/gpgsync/"
+url="https://github.com/firstlookmedia/gpgsync"
license=('GPL3')
-depends=('python-setuptools' 'python-pyqt5' 'python-nose' 'python-requests' 'python-pysocks' 'python-packaging' 'python-dateutil' 'gnupg')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/firstlookmedia/${pkgname}/archive/v${pkgver}.tar.gz" gpgsync.{service,timer})
-sha512sums=('341dd08853929b50adff5247decb8844dafa0dbe43ccb0541f6578815c78a6019a27daa15d913e43200f2dca4567e215658b357408f1866536729e78c95615b8'
- '26a56775912d680ce34c32c5e24a3dd5826b3ea78c6c3d4295d8da199d881b30c200631fd0a49077c3b4617e4941cbcd57a342e535939ea04fe4e489f15f9d18'
- 'f4d02c8d001d42db99e1cbc746b92ef41b15c13a3c3ad3e972f570d67f8f4d31b87ba7ee9440fcae190b38ee32d1f46f835a93c845cd6ac982aaea441f1ae8a9')
+depends=('gnupg' 'python-dateutil' 'python-packaging' 'python-pyqt5' 'python-pysocks' 'python-requests')
+makedepends=('python-build' 'python-installer' 'python-poetry-core' 'python-setuptools' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$pkgname".{service,timer})
+sha256sums=('f630127830bdf532ef324c18bf55c932d072ccf4e98a1730b33499891d87a604'
+ '659666bfa21f02c2dce5dd03b31ca50a2d501232a487af531bb739c0e7b356ad'
+ 'ae7fbc654db000ddcbc1c24be946865a830026e418031b600e16f293c230087c')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
- install -Dm644 -t "$pkgdir/usr/lib/systemd/user" gpgsync.{service,timer}
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 "$srcdir/$pkgname".{service,timer} -t "$pkgdir/usr/lib/systemd/user/"
}
+
# vim:set ts=2 sw=2 et