summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 21:53:58 +0100
committerBartłomiej Piotrowski2018-01-06 21:53:58 +0100
commit15af9eb3a69d2973b1bec636282a30993fc7e0c3 (patch)
tree9e79d2f51745376a8485174097ae57423a9381a8 /PKGBUILD
downloadaur-gpointing-device-settings.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e451ae318fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Thomas Mudrunka <harvie@@email..cz>
+
+pkgname=gpointing-device-settings
+pkgver=1.5.1
+pkgrel=5
+pkgdesc="GUI tool for setting pointing device such as TrackPoint or Touchpad"
+arch=('x86_64')
+license=('GPL')
+url="https://wiki.gnome.org/Attic/GPointingDeviceSettings"
+depends=('gtk2' 'gconf')
+makedepends=('gnome-settings-daemon' 'intltool')
+source=("http://sourceforge.jp/frs/redir.php?m=iij&f=/gsynaptics/45812/$pkgname-$pkgver.tar.gz"
+ "fix-build.patch")
+md5sums=('1d1491473df8eabca3c15c997a975d7f'
+ 'cc42b7bcd69fb43ae5bfbe6e1d540713')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Fix build
+ patch -Np1 -i "${srcdir}/fix-build.patch"
+
+ # Disable GSD plugin (won't build with GSD 3.8)
+ sed -i 's/ gnome-settings-daemon-plugins//' modules/Makefile.am
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -fi
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --disable-static --disable-schemas-install \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # Remove GConf schema (used by GSD plugin)
+ rm -r "${pkgdir}/usr/share/gconf"
+}