summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Lester2015-08-12 20:49:48 -0700
committerStephen Lester2015-08-12 20:49:48 -0700
commit61c90e68d35894143b75943a1ee755eaae484210 (patch)
tree44d0688398557c47c66a08c809227d712784b351 /PKGBUILD
downloadaur-61c90e68d35894143b75943a1ee755eaae484210.tar.gz
Moving over to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e35666eac8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=gppcscconnectionplugin
+pkgver=1.1.0
+gplib=6.0.0
+pkgrel=1
+pkgdesc="GlobalPlatform pcsc connection plugin"
+license=('GPL3')
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/globalplatform/"
+depends=('glibc' 'pcsclite' 'openssl' 'globalplatform')
+source=("https://sourceforge.net/projects/globalplatform/files/GlobalPlatform Library/GlobalPlatform Library ${gplib}/gppcscconnectionplugin-${pkgver}.tar.gz")
+options=('!libtool')
+md5sums=('616ca9d75620e4652b726b06ae5f44c9')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+
+ msg "Patching Makefiles"
+ sed -i 's/gnu-ldl/gnu/g' Makefile src/Makefile
+
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install || return 1
+}