summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Johansen2022-12-23 12:40:24 +0100
committerDan Johansen2022-12-23 12:40:24 +0100
commit4737ef99571012d8f8f726404c3235ee7c6da7fb (patch)
tree329297843973fb7492af46ff5159780855cd4513 /PKGBUILD
parent6ebeec5ceab2bcbe363f7f794ba40b8440e11a8d (diff)
downloadaur-4737ef99571012d8f8f726404c3235ee7c6da7fb.tar.gz
update to 2.02 and add new dependencies
Signed-off-by: Dan Johansen <strit@manjaro.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2f5e3116385..44bceef95c55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
pkgname=gpu-viewer
_pkgname=GPU-Viewer
-pkgver=1.43
+pkgver=2.02
pkgrel=1
pkgdesc="A frontend to glxinfo and vulkaninfo."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/arunsivaramanneo/GPU-Viewer/"
license=('GPL3')
-depends=('gtk3' 'python' 'python-gobject' 'python-click' 'vulkan-tools' 'clinfo' 'mesa-utils' 'vdpauinfo')
+depends=('gtk4' 'libadwaita' 'python' 'python-gobject' 'python-click' 'vulkan-tools' 'clinfo' 'mesa-utils' 'vdpauinfo')
makedepends=('meson' 'ninja')
optdepends=('nvidia: Vulkan nvidia driver'
'mesa'
+ 'orchis-theme: Preferred GTK theme'
'vulkan-radeon: Vulkan AMD drivers'
'vulkan-intel: Vulkan Intel drivers')
source=("https://github.com/arunsivaramanneo/$_pkgname/archive/v$pkgver.tar.gz")
build() {
cd "$_pkgname-$pkgver"
- meson -D prefix=/usr _build
+ meson setup -D prefix=/usr _build
}
package() {
@@ -26,4 +27,4 @@ package() {
DESTDIR="$pkgdir" ninja install
}
-md5sums=('7ad98f2d1351337f46072373c9eabec6')
+md5sums=('0472cf12c84288e2dad4bb2ddbc3f0e7')