summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Harvey2019-09-24 17:14:41 +0800
committerAdam Harvey2019-09-24 17:14:41 +0800
commit304099f0df726b0280a0e6d47e68467129c65a9a (patch)
treeaef45c22002ad9aa7518ca1f3a88c830b19f8b62 /PKGBUILD
downloadaur-304099f0df726b0280a0e6d47e68467129c65a9a.tar.gz
Initial commit of 1.6.1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50de31221d25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Adam Harvey <adam@adamharvey.name>
+
+pkgname=gpup
+pkgver=1.6.1
+pkgrel=1
+pkgdesc='A command to upload photos and movies to your Google Photos Library'
+arch=('x86_64')
+url="https://github.com/int128/gpup"
+license=('Apache')
+makedepends=('go-pie')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('c36490c8ecb0f1b68d4e5947a45a03398f376d666f8037e6be43dd7bf95f901d')
+
+build() {
+ cd $pkgname-$pkgver
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}