summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikolay Korotkiy2018-04-12 22:37:42 +0300
committerNikolay Korotkiy2018-04-12 22:37:42 +0300
commitfbdc81a8531ba603fa8636a26892e8c198bc9bce (patch)
treef22d3d87bb6f36cbd5a5a7272bec1e1b124347fb /PKGBUILD
parentefbfe11e2c579e65b4ac10022b0bef23c2a4c157 (diff)
downloadaur-fbdc81a8531ba603fa8636a26892e8c198bc9bce.tar.gz
Fix deps, remove obsolete .desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 23 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1c4f0d8a560..d28a815374fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,42 @@
# Contributor: Raffaele Zamorano
-# Maintainer: Jose Riha <jose1711 gmail com>
-pkgname=gpxsee-git
+# Contributor: Jose Riha <jose1711 gmail com>
+# Maintainer: Nikolay Korotkiy <sikmir@gmail.com>
+_orgname=tumic0
_pkgname=gpxsee
+_branch=master
+pkgname=${_pkgname}-git
+pkgver=5.6.r905.f64e882
pkgrel=1
-pkgver=r794.18fc6cc
pkgdesc='GPX viewer and analyzer'
-arch=('any')
+arch=('i686' 'x86_64')
url="http://www.gpxsee.org/"
-license=('gpl3')
-depends=('qt5-tools')
-makedepends=('git')
-conflicts=('gpxsee')
-provides=('gpxsee')
-md5sums=('SKIP'
- '4226c05418da218c2a271e1c5d1453fd')
-
-source=("${pkgname}"::git+http://github.com/tumic0/GPXSee
- "gpxsee.desktop")
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git' 'qt5-tools')
+optdepends=('qt5-imageformats: Support for TIFF')
+provides=("${pkgname//-git}=${pkgver}")
+conflicts=(${pkgname//-git})
+source=("${_pkgname}-${_branch}::git+http://github.com/${_orgname}/${_pkgname}.git#branch=${_branch}")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${_pkgname}-${_branch}
+
+ RELEASE="$(git describe --tags $(git rev-list --tags --max-count=1))"
+ REVISION="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "%s.r%s" "${RELEASE}" "${REVISION}"
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd ${_pkgname}-${_branch}
+
lrelease-qt5 gpxsee.pro
qmake gpxsee.pro
make
}
package() {
- cd "${pkgname}"
+ cd ${_pkgname}-${_branch}
install -d 755 ${pkgdir}/usr/bin
install -d 755 ${pkgdir}/usr/share/applications