summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryhfudev2015-10-07 12:35:48 -0400
committeryhfudev2015-10-07 12:35:48 -0400
commitd9a41b9cc20135282c51f60294f04222eec01d7a (patch)
treecc79268b54201129accdf2e9a6b1548861e1c7c4 /PKGBUILD
parent17426e9e74311f83385b39243200dbf8440002cf (diff)
downloadaur-d9a41b9cc20135282c51f60294f04222eec01d7a.tar.gz
update the dependents
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 18 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9622a14bda50..f0e74831b326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,27 @@
# Maintainer: 0xfc <sfc_0@yahoo.com.cn>
# Modified from rtl-sdr-git PKGBUILD
pkgname=gr-osmosdr-git
-pkgver=0.1.4.45.g46e9539
+pkgver=0.1.4.48.g86ad584
pkgrel=1
pkgdesc="GNU Radio source block for OsmoSDR, which is a 100% Free Software based small form-factor inexpensive SDR (Software Defined Radio) project."
arch=('i686' 'x86_64')
url="http://sdr.osmocom.org/trac/"
license=('GPL')
-depends=('gnuradio' 'swig' 'rtl-sdr' 'libuhd')
-makedepends=('git' 'cmake' 'boost' 'python2-cheetah')
-provides=('gr-osmosdr')
+depends=(
+ 'gnuradio'
+ 'swig'
+ 'rtl-sdr'
+ 'libuhd'
+ 'airspy-git'
+ )
+makedepends=(
+ 'git'
+ 'cmake'
+ 'boost'
+ 'python2-cheetah'
+ )
+#optdepends=()
+provides=('gr-osmosdr' 'gnuradio-osmosdr')
source=('git://git.osmocom.org/gr-osmosdr')
md5sums=('SKIP')
@@ -45,7 +57,8 @@ build() {
#cd "$srcdir/$_gitname-build/"
cd "$srcdir/$_gitname"
- mkdir build
+ #rm -rf build
+ mkdir -p build
cd build
# cmake ../
cmake -DPYTHON_EXECUTABLE=$(which python2) -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python2*) -DPYTHON_LIBRARY=$(echo /usr/lib/libpython2.*.so) -DCMAKE_INSTALL_PREFIX=/usr ../