summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Werkmeister2019-11-25 00:15:58 +0100
committerLucas Werkmeister2019-11-25 00:15:58 +0100
commit55b4504ac0afd72c889893452dea3ed851781603 (patch)
treeee7efed0847fa96a65000ef625ddec495525da07 /PKGBUILD
parent0a3bf9e6170b3c55da12630a659c7d71ea317dd3 (diff)
downloadaur-55b4504ac0afd72c889893452dea3ed851781603.tar.gz
Turn into virtual package for update to 19.3.0
With the 19.3.0 release, GraalVM supports two Java versions: Java 8 and Java 11. Accordingly, this package is split into two: jdk8-graalvm-bin and jdk11-graalvm-bin. To leave old installs functional when they update, this package is retained, but only as a “virtual” package with no contents except for its dependencies. Since this package only used to provide Java 8, it now declares a dependency on jdk8-graalvm-bin (users may install jdk11-graalvm-bin additionally or instead, if they want to). Users should explicitly install the real package; I intend to remove this one eventually.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 8 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f6528dc40c7..e1fde9f0696e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,15 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
-pkgname_=graal
-pkgname=${pkgname_}-bin
-pkgver_=19.2.1
-pkgver=${pkgver_/-/_}
+pkgname=graal-bin
+pkgver=19.3.0
pkgrel=1
-pkgdesc='Universal virtual machine for running applications written in a variety of languages (JVM-based, LLVM-based, or other)'
+pkgdesc='Virtual package for backwards compatibility; please directly install jdk8-graalvm-bin instead'
arch=('x86_64')
url='https://www.graalvm.org/'
license=('custom')
-depends=('java-runtime-common'
- 'java-environment-common')
-makedepends=()
+depends=('jdk8-graalvm-bin')
optdepends=('graal-native-image: plugin to generate native binary images (used to be bundled with this package before the 19.0.0 release)')
-provides=('java-runtime=8'
- 'java-environment=8'
- "$pkgname_")
-conflicts=("$pkgname_")
-install="$pkgname.install"
-source=("https://github.com/oracle/$pkgname_/releases/download/vm-${pkgver_}/graalvm-ce-linux-amd64-${pkgver_}.tar.gz")
-sha256sums=('c3af1238c8021cbf018e4824a39823a246256596979bd6ec55685ccf661b253b')
-
-package() {
- cd "${pkgname_}vm-ce-${pkgver_}"
- mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" *
- install -DTm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=()
+sha256sums=()