summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Werkmeister2018-04-28 00:07:44 +0200
committerLucas Werkmeister2018-04-28 00:07:44 +0200
commitb7a464b00fc0800a5efbf7b6fab9960e96627260 (patch)
tree044d3a0d2a029525529c00b483be779c902a7386 /PKGBUILD
downloadaur-b7a464b00fc0800a5efbf7b6fab9960e96627260.tar.gz
Initial commit
Just copy the entire distribution zip into a directory under /usr/lib/jvm; this is already sufficient to make the package work with archlinux-java (though we don’t automatically set it up yet).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7787e8bd6e23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
+
+pkgname=graal
+pkgver_=1.0.0-rc1
+pkgver=${pkgver_/-/_}
+pkgrel=1
+pkgdesc='Universal virtual machine for running applications written in a variety of languages (JVM-based, LLVM-based, or other)'
+arch=('x86_64')
+url='https://www.graalvm.org/'
+license=('custom')
+depends=('java-environment-common')
+makedepends=()
+optdepends=()
+provides=('java-environment=8')
+source=("https://github.com/oracle/graal/releases/download/vm-${pkgver_}/graalvm-ce-${pkgver_}-linux-amd64.tar.gz")
+sha256sums=('08474e5b934e44f515df6c0449289b20b26990a9fc45fe0a58901d181117e009')
+
+package() {
+ cd "${pkgname}vm-${pkgver_}"
+ mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/"
+ cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" *
+ install -Dm644 GraalCE_license_3rd_party_license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}