summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBilal Elmoussaoui2016-07-31 01:32:38 +0200
committerBilal Elmoussaoui2016-07-31 01:32:38 +0200
commit50f0577815aaf205d10a4823ef2b97c9fec447d4 (patch)
tree01955511fff91ae17adf9e597af7c7025a56c4c7 /PKGBUILD
downloadaur-50f0577815aaf205d10a4823ef2b97c9fec447d4.tar.gz
first stable release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dac3477b038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
+
+pkgname=gradio
+_gitname=gradio
+pkgver=4.0.1
+pkgrel=1
+pkgdesc='A GTK3 app for finding and listening to internet radio stations'
+arch=('i686' 'x86_64')
+license=('GPL3')
+url="https://github.com/haecker-felix/gradio"
+depends=('desktop-file-utils' 'gstreamer' 'json-glib' 'libgee' 'libsoup')
+makedepends=('git' 'gnome-common' 'intltool' 'itstool' 'vala' 'yelp-tools' 'cmake')
+options=('!emptydirs')
+install=gradio.install
+source=("https://github.com/haecker-felix/${_gitname}/archive/v${pkgver}.zip")
+md5sums=('7c50e0dc0ec944d0a7893d8a7df1c41a')
+conflicts=('gradio-git')
+provides=("gradio=$pkgver")
+
+build() {
+ cd "$srcdir/gradio-${pkgver}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/gradio-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+}