summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBilal Elmoussaoui2017-09-13 11:36:19 +0200
committerBilal Elmoussaoui2017-09-13 11:36:19 +0200
commitf9a84d35f99cf03a95bde728cd85ccd2fdf9b043 (patch)
treebd387b8a3b9227aeb287a8247d1f40b4acd6b697 /PKGBUILD
parent43230a5fdad05391fad14bf85e017529330d637a (diff)
downloadaur-f9a84d35f99cf03a95bde728cd85ccd2fdf9b043.tar.gz
update to meson build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a98f0c5762c..917e99ab66f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,28 @@
pkgname=gradio-git
_gitname=gradio
-pkgver=5.0.0
-pkgrel=3
+pkgver=6.0.0
+pkgrel=1
pkgdesc='A GTK3 app for finding and listening to internet radio stations'
arch=('i686' 'x86_64')
license=('GPL3')
url="https://github.com/haecker-felix/gradio"
-depends=('desktop-file-utils' 'gstreamer' 'gst-plugins-ugly'
-'gst-plugins-bad' 'gst-plugins-good' 'gst-plugins-good' 'json-glib'
-'libgee'
-'libsoup')
-makedepends=('git' 'gnome-common' 'intltool' 'itstool' 'vala' 'yelp-tools' 'cmake')
-
+depends=('desktop-file-utils' 'gstreamer' 'gst-plugins-ugly'
+'gst-plugins-bad' 'gtk3' 'gobject-introspection' 'gst-plugins-base' 'gst-plugins-good' 'json-glib'
+'libgee' 'sqlite3' 'libsoup')
+makedepends=('git' 'gnome-common' 'meson' 'gettext' 'appstream-glib' 'vala' 'yelp-tools')
options=('!emptydirs')
-install=gradio.install
source=("git://github.com/haecker-felix/${_gitname}.git")
md5sums=('SKIP')
conflicts=('gradio' 'gradio-bin')
provides=("gradio=$pkgver")
build() {
- cd "$srcdir/${_gitname}"
- ./autogen.sh --prefix=/usr
- make
+ cd "${srcdir}/${_gitname}"
+ meson builddir --prefix=/usr
}
package() {
- cd "$srcdir/${_gitname}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${_gitname}"
+ DESTDIR="${pkgdir}" ninja -C builddir install
}