aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikita Bobko2020-02-03 05:35:53 +0300
committerNikita Bobko2020-02-03 05:35:53 +0300
commit225240a1b126e10d2637da6d2dc1ec0214be6f5a (patch)
treea484334f209c4105ac7d59a93dbf382a78e701d7 /PKGBUILD
downloadaur-225240a1b126e10d2637da6d2dc1ec0214be6f5a.tar.gz
Init `master_fa72b79` version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7abf8126c496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Nikita Bobko <echo bmlraXRhYm9ia29AZ21haWwuY29tCg== | base64 -d>
+
+pkgname=gradle-zsh-completion
+pkgdesc="zsh completion for Gradle"
+pkgver=master_fa72b79
+pkgrel=1
+arch=("any")
+url="https://github.com/gradle/gradle-completion"
+license=("MIT")
+makedepends=('git')
+source=('git+https://github.com/gradle/gradle-completion.git')
+md5sums=('SKIP')
+
+package() {
+ cd gradle-completion || return 1
+ # It must be git checkout "v$pkgver". But they not released yet commit
+ # which includes zsh support. So using version from particular commit
+ git checkout fa72b79 >/dev/null 2>&1 || return 1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 gradle-completion.plugin.zsh "${pkgdir}/usr/share/zsh/plugins/${pkgname}/gradle-completion.plugin.zsh"
+ install -Dm644 _gradle "${pkgdir}/usr/share/zsh/site-functions/_gradle"
+}