summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOrhun Parmaksız2023-09-10 21:50:35 +0300
committerOrhun Parmaksız2023-09-10 21:50:35 +0300
commit88ed9dd1f1d4ca1ce02335d10b02442a22d9c73a (patch)
treeee2191fc49c772ee3b2042e827b2d47c185d23cb /PKGBUILD
parent43debc6488c1a983358da9ed22a55a128fa8ea13 (diff)
downloadaur-88ed9dd1f1d4ca1ce02335d10b02442a22d9c73a.tar.gz
upgpkg: graphenex 1.4.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e873840bf01..48f470568e1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,26 @@
# https://github.com/orhun/pkgbuilds
pkgname=graphenex
-_pkgname=GrapheneX
-pkgver=1.3.1
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc="Automated System Hardening Framework"
+arch=('x86_64')
url="https://github.com/grapheneX/grapheneX"
-depends=('python' 'python-flask-socketio' 'python-coloredlogs'
+depends=('python-flask-socketio' 'python-coloredlogs'
'python-terminaltables' 'python-pyinquirer' 'python-psutil'
'python-colorama')
-makedepends=('python-setuptools' 'python-dephell')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
license=('GPL3')
-arch=('x86_64')
-source=("https://files.pythonhosted.org/packages/source/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('fd9d49d609083bc518d7412a1f5aa62f')
-
-prepare() {
- cd "$_pkgname-$pkgver"
- dephell deps convert --from pyproject.toml --to setup.py
-}
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha512sums=('b60bae3228948d7beea862df62bd195b0eb3dd0d7517cbe69737d61aac39c42d44dab3477dca5d5e0cc8d95305044e13a1c712c153c5c5d030ccd3b0231f36a9')
build() {
- cd "$_pkgname-$pkgver"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}