summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-08-26 21:00:03 -0400
committerVincent Grande2020-08-26 21:00:03 -0400
commite2d6c024a73e09e8cfe9c0b7a7b4e9826e0c801a (patch)
treef7df504e972781c9eebb9da32a0f973a7693cdaa /PKGBUILD
downloadaur-e2d6c024a73e09e8cfe9c0b7a7b4e9826e0c801a.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd667d811ab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=graphite-git
+pkgver=1.3.14
+pkgrel=1
+epoch=1
+arch=('x86_64')
+url="https://github.com/silnrsi/graphite"
+pkgdesc='reimplementation of the SIL Graphite text processing engine'
+license=('LGPL' 'GPL' 'custom')
+provides=(graphite)
+conflicts=(graphite)
+depends=('gcc-libs')
+makedepends=('cmake' 'freetype2' 'python'
+ # for documentation
+ 'doxygen' 'dblatex' 'graphviz' 'asciidoc')
+checkdepends=('python-fonttools')
+options=('!emptydirs')
+source=(git+https://github.com/silnrsi/graphite)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd build
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ mkdir build
+ cd build
+ cmake -G "Unix Makefiles" ../graphite2-${pkgver} \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DGRAPHITE2_COMPARE_RENDERER=OFF \
+
+ # fix unwanted -O3 cflag (taken form Debian)
+ find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
+
+ make
+ make -j1 docs
+}
+
+#check() {
+# cd "${srcdir}"/build
+# ctest || true
+#}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="$pkgdir/" install
+ # install doc files
+ mkdir -p "${pkgdir}"/usr/share/doc/graphite2/api
+ cp -vrf doc/doxygen/{html,latex/refman.pdf} "${pkgdir}"/usr/share/doc/graphite2/api
+ cp -vrf doc/{GTF,manual}.html "${pkgdir}"/usr/share/doc/graphite2
+
+ # licenses
+ mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m644 "${srcdir}"/graphite2-${pkgver}/COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
+}