summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPantelis Panayiotou2024-03-22 19:00:05 +0200
committerPantelis Panayiotou2024-03-22 19:00:05 +0200
commit6fac5b5c648e2d0ed3a2ddfa1c9e985f662953ee (patch)
tree66c0f2cf9be8a060e81bc6199575eef75c4b8f0b /PKGBUILD
downloadaur-6fac5b5c648e2d0ed3a2ddfa1c9e985f662953ee.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa553ff5e081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Pantelis Panayiotou <p.panayiotou@gmail.com>
+
+pkgname=graphs
+pkgver=1.7.2
+pkgrel=1
+pkgdesc="Plot and manipulate data (Gnome Circle app)"
+
+arch=('x86_64')
+url="https://welcome.gnome.org/app/Graphs/"
+license=('GPL-3.0-or-later')
+depends=('gtk4' 'libadwaita' 'python-matplotlib' 'python-scipy' 'python-numpy' 'python-numexpr' 'python-sympy' 'gobject-introspection')
+provides=('graphs')
+makedepends=('git' 'meson' 'blueprint-compiler' 'gettext' 'vala' 'gobject-introspection-runtime')
+source=("https://gitlab.gnome.org/World/Graphs/-/archive/v${pkgver}/Graphs-v${pkgver}.tar.gz")
+sha256sums=('90616099e3224c1fae0bfbe23faedf635936f101bae2f75e28fc8d7c2a845638')
+
+build() {
+ cd "Graphs-v${pkgver}"
+ meson setup --buildtype=release "build/"
+ cd "build/"
+ meson configure -Dprefix="/usr"
+ meson compile
+}
+
+package() {
+ cd "Graphs-v${pkgver}"
+ cd "build/"
+ meson install --destdir="${pkgdir}"
+}