summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Joost van de Sande2021-01-08 13:52:56 +0100
committerPieter Joost van de Sande2021-01-08 13:52:56 +0100
commitcf8c6ee4a914a645a8346e1a8198eb1312e175b6 (patch)
tree57b0542a4b770963d00716d9c6ef4def99339003 /PKGBUILD
downloadaur-cf8c6ee4a914a645a8346e1a8198eb1312e175b6.tar.gz
initial release 0.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fcf6909b756
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=grasp
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Create strong passwords using words that are easy for you to remember. A password manager that does not require any type of storage'
+arch=('x86_64')
+url="https://github.com/lucasepe/grasp"
+makedepends=("go" "git")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('23cb977b5ee435c9a0540976c6fa82e9c282cf6dca0a37fc99303a88a83cd332')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+
+ go get ./...
+ go build -o ${pkgname} -ldflags "-extldflags ${LDFLAGS} -s -w -X main.version=${pkgver}" .
+}
+
+package() {
+ install -Dm755 "${pkgname}-${pkgver}/${pkgname}" ${pkgdir}/usr/bin/${pkgname}
+}