summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkikislater2023-03-05 09:12:37 +0400
committerkikislater2023-03-05 09:12:37 +0400
commit0710d38f75f2f5c9f013df07665d372a162e4c8d (patch)
tree5a7ca1fe7262813dee08fde374352062129ac3f2 /PKGBUILD
parentde756a57c2a62317476f42aa1d305bb4e79b8d0f (diff)
downloadaur-0710d38f75f2f5c9f013df07665d372a162e4c8d.tar.gz
Link pygrass to standard site-packages installation allowing to launch pygrass in Python shell or IDE
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c520d51fcfb9..4e23eb5d7247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=grass
pkgver=8.2.1
-pkgrel=1
+pkgrel=2
_shortver=${pkgver%.*}; _shortver=${_shortver/./}
pkgdesc='Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization'
arch=('i686' 'x86_64')
@@ -61,4 +61,8 @@ package() {
include/Make/{Platform,Grass}.make \
etc/fontcap \
"$pkgdir/usr/bin/grass"
+
+ # Link pygrass to main python site-packages
+ mkdir -p "$pkgdir/usr/lib/python3.10/site-packages/"
+ ln -s "$pkgdir/opt/grass/etc/python/grass" "$pkgdir/usr/lib/python3.10/site-packages/grass"
}