summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2017-06-12 18:56:54 -0500
committerDoug Newgard2017-06-12 18:56:54 -0500
commit5dc428ae487be5e21d44df831588e6dd7f5971f6 (patch)
tree9abe13f05406ec99194ee6eff739bbf1d3e1699b /PKGBUILD
parentdb63e582f1ed0c64da2cd2233315168078ecddbb (diff)
downloadaur-5dc428ae487be5e21d44df831588e6dd7f5971f6.tar.gz
Fix for GCC7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ece68d8fe22..40034ab7e9f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,12 +15,17 @@ depends=('cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos' 'glibc
makedepends=('libxt')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
-source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz")
-md5sums=('5c858c718d40a4f3e82741e60c9f7b97')
+source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz"
+ "https://trac.osgeo.org/grass/raw-attachment/ticket/3331/ctypesgencore_preprocessor_fix.diff")
+md5sums=('5c858c718d40a4f3e82741e60c9f7b97'
+ '2b70a7ddece3563dc5cf4b95b5b45665')
prepare() {
cd $pkgname-$pkgver
+ # GCC7 patch
+ patch -Np0 -i ../ctypesgencore_preprocessor_fix.diff
+
# Change everything to use python2
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
sed -i '/os\.environ.*GRASS_PYTHON/ s/"python"/"python2"/' lib/init/grass.py